Re. [Oberon] DAV WebDAV.1.1.0 released
Edgar wrote:
I just put a new WebDAV on http://webdav.ethz.ch/davzip/WebDAV.1.1.0.Zip (115KB) For testing with write access send me a mail for a password. Main new feature is a user interface modeled like FATDocs. Read es.DAVDocs.Text. Rest of documentation needs to be updated. For WebDAV/DeltaV see http://www.webdav.org, http://www.webdav.org/deltav
I vaugely remember this is connected with: * co-operative development - instead of people hacking privately, * formally controlled versions of the iterative development proccess. Both facilities which I have been (repeatedly) advocating. So I though "I must make an effort". Here's the log/trace of the start of my painfull journey - for possible guidance (avoid the same mistakes) of others: 1. Search files of the appropriate partition for reference to "WebDAV" -> mentioned RFC2518 2. Based on URLs of RFCs on hand, fetch http://www.ietf.org/rfc/rfc2518.txt 3. This 203K monster refers to several other RFCs: RFC2119, RFC2291 - which I might fetch, or not. 4. Fortunately, with n-o I can 'Koki-pen-colour-mark' parts of the text as I perhaps read 5 pages a day of the total 92 pages. Those restricted to Windows or Linux must print to paper ? And then how do they find 'other references to "string-x" in the document' ? I can't live without n-o. 5. I see much reference to XML. I've always had negative attitude to over use of HTML. XML seem to be more of the same ? Someone refered to XML as Xmas wrapping for garbage. What do you think about these web-publications where pages are typically of 6 lines, with 4 links to the next layer. No substance - all fluff. So I'll have to read an XML tutor as well ?! 6. reading this:--
Some proposals come from a digital library perspective. These include the Dublin Core [RFC2413] metadata set and the Warwick Framework [WF], a container architecture for different metadata schemas. The literature includes many examples of metadata, including MARC [USMARC], a bibliographic metadata format, and a technical report bibliographic format employed by the Dienst system [RFC1807]. Additionally, the proceedings from the first IEEE Metadata conference describe many community-specific metadata sets.
Participants of the 1996 Metadata II Workshop in Warwick, UK [WF], noted that "new metadata sets will develop as the networked .... ...bla...bla reminded me of the UN: gathering of wind-bags.
Perhaps that's why the US said: "no thank you, we'll do it ourselves" ? Perhaps that's why people just hack away in private ? Perhaps I should have read http://www.webdav.org/ first ? How much effort is to be invested before usage of WebDAV starts paying dividends ? -- Chris Glur.
--- eas-lab@absamail.co.za wrote:
Here's the log/trace of the start of my painfull journey - for possible guidance (avoid the same mistakes) of others:
Does your "painfull journey" include actually downloading WebDAV for Oberon and testing it out? There are a few "kinks" in it but overall it seems to work quite nicely.
5. I see much reference to XML. I've always had negative attitude to over use of HTML. XML seem to be more of the same ? Someone refered to XML as Xmas wrapping for garbage.
Then ya ain't gonna like BlueBottle GUI because it's based on XML. :)
What do you think about these web-publications where pages are typically of 6 lines, with 4 links to the next layer. No substance - all fluff. So I'll have to read an XML tutor as well ?!
No. Not if you simply want to USE WebDAV. If you want to help DEVELOP WebDAV then yes, you'll need to know something about XML. (I haven't heard any requests from Edgar from help on WebDAV development at the moment.)
How much effort is to be invested before usage of WebDAV starts paying dividends ?
-- Chris Glur.
Much of the investment has already been done by Edgar. You don't have to understand all of the RFCs behind WebDAV to use it, just like you don't have to understand all of the RFCs behind HTTP to use a webbrowser. Of course if you run into a bug (and considering how early it is in the product lifecyle that's highly possible) knowing how the underlying protocal works can help. In my own experience I was able to upload a file to the experimental webdav, upload a modified version, "rollback" to a previous version, ect. I ran into a problem downloading, but I think it was due to a bug in WinAosOberon. Edgar sent me the fix, but I haven't tested that out yet. Regards, John M. Drake __________________________________ Do you Yahoo!? Yahoo! SiteBuilder - Free, easy-to-use web site design software http://sitebuilder.yahoo.com
participants (2)
-
eas-lab@absamail.co.za -
John Drake